<!DOCTYPE html>
<!--[if IE 9]>
<html class="ie9 lt-ie10" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, height=device-height, initial-scale=1, user-scalable=no">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://iosdeveloperblog.com/xmlrpc.php">

	<title>iOS Developer Blog - All Things iOS</title>

<!-- This site is optimized with the Yoast SEO plugin v4.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="All Things iOS"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://iosdeveloperblog.com/" />
<link rel="next" href="https://iosdeveloperblog.com/page/2/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:title" content="iOS Developer Blog - All Things iOS" />
<meta property="og:description" content="All Things iOS" />
<meta property="og:url" content="https://iosdeveloperblog.com/" />
<meta property="og:site_name" content="iOS Developer Blog" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="All Things iOS" />
<meta name="twitter:title" content="iOS Developer Blog - All Things iOS" />
<meta name="twitter:site" content="@iosdevelopblog" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/iosdeveloperblog.com\/","name":"iOS Developer Blog","potentialAction":{"@type":"SearchAction","target":"https:\/\/iosdeveloperblog.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"https:\/\/iosdeveloperblog.com\/","sameAs":["https:\/\/www.linkedin.com\/in\/eshwar-satrasala-996764129","https:\/\/twitter.com\/iosdevelopblog"],"@id":"#person","name":"Esh Satrasala"}</script>
<meta name="google-site-verification" content="_yrT5_PIVnpLmvewrrN2BeUKxiAZAqv4mVVmq8eXB5Y" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="iOS Developer Blog &raquo; Feed" href="https://iosdeveloperblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="iOS Developer Blog &raquo; Comments Feed" href="https://iosdeveloperblog.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/iosdeveloperblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='hive-font-awesome-style-css'  href='https://iosdeveloperblog.com/wp-content/themes/hive/assets/css/font-awesome.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='hive-style-css'  href='https://iosdeveloperblog.com/wp-content/themes/hive/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='hive-child-style-css'  href='https://iosdeveloperblog.com/wp-content/themes/hive-child-master_2/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='hive-fonts-css'  href='//fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700%2C400italic%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='gem-base-css'  href='https://iosdeveloperblog.com/wp-content/plugins/godaddy-email-marketing-sign-up-forms/css/gem.min.css?ver=1.2.0' type='text/css' media='all' />
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>
<script type='text/javascript' src='https://v0.wordpress.com/js/videopress.js?ver=1.09'></script>
<link rel='https://api.w.org/' href='https://iosdeveloperblog.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://iosdeveloperblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://iosdeveloperblog.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.5" />
		<!-- Custom Logo: hide header text -->
		<style id="custom-logo-css" type="text/css">
			.site-title, .site-description-text {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
		</style>
	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-73365403-3', 'auto');
  ga('send', 'pageview');

</script><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://iosdeveloperblog.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="https://iosdeveloperblog.com/wp-content/uploads/2017/03/cropped-idb_icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://iosdeveloperblog.com/wp-content/uploads/2017/03/cropped-idb_icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://iosdeveloperblog.com/wp-content/uploads/2017/03/cropped-idb_icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://iosdeveloperblog.com/wp-content/uploads/2017/03/cropped-idb_icon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


/* ADD YOUR NEW CSS RULES HERE */

.site-info a, .site-info span:not(.site-info-additional-text) {
display: none;
}

@media only screen and (min-width: 1359px) {
.category-tutorials .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-design .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-books .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-productivity .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-jobs .o-grid--3col-\@desk > * {
width: 33%;
} }

.site-footer a {
display: none;!important;
}

		</style>
	<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<style id="customify_output_style">
		
.site-branding img { max-height: 190px; }
.main-navigation ul > li a { padding-left: 36px; }
.main-navigation ul > li a { padding-right: 36px; }
.nav--main a { color: #171617; }
.nav--main > li:hover > a, .nav--main li.active > a { color: #171617; }
.nav--main > li > a:before { background-color: #171617; }
div#infinite-footer, .site-footer { background: #ffffff; }
body, .entry-title a { color: #3d3e40; }
a { color: #afafaf; }
blockquote a:hover,
.format-quote .edit-link a:hover,
.content-quote blockquote:before,
.widget a:hover,
.widget_blog_subscription input[type="submit"],
.widget_blog_subscription a:hover,
blockquote a:hover
blockquote:after { color: #ffeb00; }
select:focus,
textarea:focus,
input[type="text"]:focus,
input[type="password"]:focus,
input[type="datetime"]:focus,
input[type="datetime-local"]:focus,
input[type="date"]:focus,
input[type="month"]:focus,
input[type="time"]:focus,
input[type="week"]:focus,
input[type="number"]:focus,
input[type="email"]:focus,
input[type="url"]:focus,
input[type="search"]:focus,
input[type="tel"]:focus,
input[type="color"]:focus,
.form-control:focus { outline-color: #ffeb00; }
.widget_blog_subscription input[type="submit"] { border-color: #ffeb00; }
.highlight,
.archive__grid .accent-box,
.sticky:after,
.content-quote blockquote:after,
.sticky:not(.format-quote):after { background: #ffeb00; }
.content-quote blockquote:after{
			-webkit-box-shadow: #ffeb00 5.5em 0 0;
					box-shadow: #ffeb00 5.5em 0 0;
		}.sticky, .sticky a, .sticky .posted-on a, .sticky .entry-title{color: #000000}h1, .dropcap { color: #171617; }
h2, blockquote { color: #171617; }
h3 { color: #171617; }
h4 { color: #171617; }
h5 { color: #171617; }
.site-footer { padding-top: 30px; }
.site-footer { padding-bottom: 30px; }
.site-footer, #infinite-footer .blog-info, #infinite-footer .blog-credits { color: #000000; }
.site-footer a, #infinite-footer .blog-info a, #infinite-footer .blog-credits a { color: #7c7c7c; }
.dummy { dummy: 3px; }
.archive__grid > .grid__item,
.sticky:not(.format-quote).post { border-left-width: 80px; }
.archive__grid{ margin-left: -80px; }.archive__grid .entry-title { color: #171617; }
.entry-meta__primary,
 .entry-meta__secondary:before,
.entry-meta__secondary:hover > *,
.single .posted-on,
.single .posted-on:before,
.single .posted-by,
.single .cat-links:before,
.page .posted-on,
.page .posted-on:before,
.page .posted-by,
.page .cat-links:before,
.single .cat-links:hover,
.page .cat-links:hover { color: #171617; }
.entry-meta__secondary, 
.entry-meta__primary:hover > *,
.single .cat-links, .page .cat-links,
.single .cat-links,
.page .cat-links,
.single .posted-on:hover,
.single .posted-by:hover,
.page .posted-on:hover,
.page .posted-by:hover { color: #0c0c0c; }
@media only screen and (min-width: 1000px)  { .site-header { padding-left: 60px; }
.home .site-content,
.blog .site-content, 
.archive .site-content { padding-right: 72px; }
 }
@media only screen and (min-width: 1000px) { .site-header { padding-right: 60px; }
.home .site-content,
.blog .site-content, 
.archive .site-content { padding-left: 72px; }
 }
@media only screen and (min-width: 1359px) { .single .site-content .container, .page .site-content .container, .post .site-content .container { max-width: 1550px; }
.single .site-content, .page .site-content, .post .site-content { padding-right: 60px; }
.home .site-content .container,
.blog .site-content .container, 
.archive .site-content .container { max-width: 1360px; }
 }
@media only screen and (min-width: 1359px)  { .single .site-content, .page .site-content, .post .site-content { padding-left: 60px; }
 }
@media screen and (min-width: 1000px) { body:before, body:after { background: #ffffff; }
 }

		</style>		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


/* ADD YOUR NEW CSS RULES HERE */

.site-info a, .site-info span:not(.site-info-additional-text) {
display: none;
}

@media only screen and (min-width: 1359px) {
.category-tutorials .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-design .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-books .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-productivity .o-grid--3col-\@desk > * {
width: 33%;
} }

@media only screen and (min-width: 1359px) {
.category-jobs .o-grid--3col-\@desk > * {
width: 33%;
} }

.site-footer a {
display: none;!important;
}

		</style>
			<script type="text/javascript">
			var customify_font_loader = function () {
				var webfontargs = {
					classes: false,
					events: false
				};
								webfontargs.google = {families: ['Droid Serif:700:latin','Droid Serif:regular,italic,700,700italic:latin','Raleway:regular:latin-ext,latin','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:regular:latin-ext,latin,cyrillic','Playfair Display:900:latin-ext,latin,cyrillic']};
								WebFont.load(webfontargs);
			};

			if (typeof WebFont !== 'undefined') { 				customify_font_loader();
			} else { 				var tk = document.createElement('script');
				tk.src = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
				tk.type = 'text/javascript';

				tk.onload = tk.onreadystatechange = function () {
					customify_font_loader();
				};
				var s = document.getElementsByTagName('script')[0];
				s.parentNode.insertBefore(tk, s);
			}
		</script>
		<style id="customify_fonts_output">
.nav--main a {
font-family: Droid Serif;

font-weight: 700;

font-size: 16px;

text-transform: none;
}

html body, blockquote cite, .widget, div.sharedaddy .sd-social h3.sd-title {
font-family: Droid Serif;

font-size: 18px;

text-transform: none;
}

blockquote {
font-family: Raleway;

font-weight: normal;

font-size: 1em;

text-transform: none;
}

.dropcap, h1, .fs-36px {
font-family: Playfair Display;

font-weight: normal;

font-size: 3.38em;

text-transform: none;
}

h2 {
font-family: Playfair Display;

font-weight: normal;

font-size: 2.25em;

text-transform: none;
}

h3 {
font-family: Playfair Display;

font-weight: normal;

font-size: 1.5em;

text-transform: none;
}

h4 {
font-family: Playfair Display;

font-weight: normal;

font-size: 1.13em;

text-transform: none;
}

h5 {
font-family: Playfair Display;

font-weight: normal;

font-size: 0.83em;

text-transform: none;
}

.archive__grid .entry-title {
font-family: Playfair Display;

font-weight: normal;

font-size: 36px;

text-transform: none;
}

.entry-meta {
font-family: Playfair Display;

font-weight: 900;

font-size: 16px;

text-transform: capitalize;
}
</style>
	<!--[if !IE]><!-->
	<script>
		if (/*@cc_on!@*/false) {
			document.documentElement.className += ' ie10';
		}
	</script>
	<!--<![endif]-->
</head>

<body class="home blog wp-custom-logo group-blog u-full-width-header wpb-js-composer js-comp-ver-5.1 vc_responsive">
<div id="page" class="hfeed site">

	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		<div class="container">
			<div class="site-branding">
				<a href="https://iosdeveloperblog.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="1360" height="390" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1.jpg" class="custom-logo" alt="" itemprop="logo" srcset="https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1.jpg 1360w, https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1-300x86.jpg 300w, https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1-768x220.jpg 768w, https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1-1024x294.jpg 1024w, https://iosdeveloperblog.com/wp-content/uploads/2017/05/cropped-iosdeveloperblog_header_logo_new-1-450x129.jpg 450w" sizes="(max-width: 1360px) 100vw, 1360px" /></a>
				<h1 class="site-title site-title--large">
					<a href="https://iosdeveloperblog.com/" rel="home">
						iOS Developer Blog					</a>
				</h1>

				<div class="site-description">
					<span class="site-description-text">All Things iOS</span>
				</div>
			</div>

			<nav id="site-navigation" class="main-navigation" role="navigation">
				<h5 class="screen-reader-text">Main navigation</h5>
									<button class="navigation__trigger">
						<i class="fa fa-bars"></i><span class="screen-reader-text">Menu</span>
					</button>
				<ul id="menu-menu" class="nav  nav--main"><li id="menu-item-7882" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7882"><a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></li>
<li id="menu-item-3978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3978"><a href="https://iosdeveloperblog.com/category/news/">News</a></li>
<li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://iosdeveloperblog.com/category/articles/">Articles</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://iosdeveloperblog.com/category/design/">Design</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="https://iosdeveloperblog.com/category/productivity/">Productivity</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://iosdeveloperblog.com/category/books/">Books</a></li>
<li id="menu-item-7886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7886"><a href="https://iosdeveloperblog.com/category/dev-tools/">Dev Tools</a>
<ul class="sub-menu">
	<li id="menu-item-7900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7900"><a href="https://iosdeveloperblog.com/category/dev-tools/app-store-and-sales/">App Store Marketing &#038; Sales</a></li>
	<li id="menu-item-7888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7888"><a href="https://iosdeveloperblog.com/category/dev-tools/analytics-dev-tools/">Analytics</a></li>
	<li id="menu-item-7898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7898"><a href="https://iosdeveloperblog.com/category/dev-tools/backend-services/">Backend Services</a></li>
	<li id="menu-item-7895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7895"><a href="https://iosdeveloperblog.com/category/dev-tools/debugging/">Debugging</a></li>
	<li id="menu-item-7894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7894"><a href="https://iosdeveloperblog.com/category/dev-tools/deployment/">Deployment</a></li>
</ul>
</li>
<li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39"><a href="https://iosdeveloperblog.com/category/libraries/">Libraries</a>
<ul class="sub-menu">
	<li id="menu-item-449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-449"><a href="https://iosdeveloperblog.com/category/libraries/uiux/">UI/UX</a>
	<ul class="sub-menu">
		<li id="menu-item-674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-674"><a href="https://iosdeveloperblog.com/category/libraries/uiux/alerts/">Alerts</a></li>
		<li id="menu-item-675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-675"><a href="https://iosdeveloperblog.com/category/libraries/uiux/badge/">Badge</a></li>
		<li id="menu-item-599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-599"><a href="https://iosdeveloperblog.com/category/libraries/uiux/button/">Button</a></li>
		<li id="menu-item-677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-677"><a href="https://iosdeveloperblog.com/category/libraries/uiux/label/">Label</a></li>
		<li id="menu-item-678" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-678"><a href="https://iosdeveloperblog.com/category/libraries/uiux/layout/">Layout</a></li>
		<li id="menu-item-679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-679"><a href="https://iosdeveloperblog.com/category/libraries/uiux/menu/">Menu</a></li>
		<li id="menu-item-702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-702"><a href="https://iosdeveloperblog.com/category/libraries/uiux/navigation-bar/">Navigation Bar</a></li>
		<li id="menu-item-704" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-704"><a href="https://iosdeveloperblog.com/category/libraries/uiux/popup/">Popup</a></li>
		<li id="menu-item-703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-703"><a href="https://iosdeveloperblog.com/category/libraries/uiux/pickerview/">PickerView</a></li>
		<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-705"><a href="https://iosdeveloperblog.com/category/libraries/uiux/progress-activity-indicator/">Progress &#038; Activity Indicator</a></li>
		<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="https://iosdeveloperblog.com/category/libraries/uiux/pull-to-refresh/">Pull to Refresh</a></li>
		<li id="menu-item-707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-707"><a href="https://iosdeveloperblog.com/category/libraries/uiux/scrollview/">ScrollView</a></li>
		<li id="menu-item-708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-708"><a href="https://iosdeveloperblog.com/category/libraries/uiux/slider/">Slider</a></li>
		<li id="menu-item-709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-709"><a href="https://iosdeveloperblog.com/category/libraries/uiux/splash-view/">Splash View</a></li>
		<li id="menu-item-710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-710"><a href="https://iosdeveloperblog.com/category/libraries/uiux/stepper/">Stepper</a></li>
		<li id="menu-item-711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-711"><a href="https://iosdeveloperblog.com/category/libraries/uiux/switch/">Switch</a></li>
		<li id="menu-item-712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-712"><a href="https://iosdeveloperblog.com/category/libraries/uiux/tab-bar/">Tab Bar</a></li>
		<li id="menu-item-714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-714"><a href="https://iosdeveloperblog.com/category/libraries/uiux/tag/">Tag</a></li>
		<li id="menu-item-713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-713"><a href="https://iosdeveloperblog.com/category/libraries/uiux/table-view-collection-view/">Table View / Collection View</a></li>
		<li id="menu-item-715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-715"><a href="https://iosdeveloperblog.com/category/libraries/uiux/text/">Text</a></li>
		<li id="menu-item-716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-716"><a href="https://iosdeveloperblog.com/category/libraries/uiux/textfield-textview/">TextField &#038; TextView</a></li>
		<li id="menu-item-717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-717"><a href="https://iosdeveloperblog.com/category/libraries/uiux/transition/">Transition</a></li>
		<li id="menu-item-718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-718"><a href="https://iosdeveloperblog.com/category/libraries/uiux/walkthrough-intro-tutorial/">Walkthrough / Intro / Tutorial</a></li>
	</ul>
</li>
	<li id="menu-item-643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-643"><a href="https://iosdeveloperblog.com/category/libraries/analytics/">Analytics</a></li>
	<li id="menu-item-447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447"><a href="https://iosdeveloperblog.com/category/libraries/animation/">Animation</a></li>
	<li id="menu-item-645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-645"><a href="https://iosdeveloperblog.com/category/libraries/app-store/">App Store</a></li>
	<li id="menu-item-646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-646"><a href="https://iosdeveloperblog.com/category/libraries/apple-tv/">Apple TV</a></li>
	<li id="menu-item-451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451"><a href="https://iosdeveloperblog.com/category/libraries/audio/">Audio</a></li>
	<li id="menu-item-649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-649"><a href="https://iosdeveloperblog.com/category/libraries/calendar/">Calendar</a></li>
	<li id="menu-item-648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-648"><a href="https://iosdeveloperblog.com/category/libraries/cache/">Cache</a></li>
	<li id="menu-item-650" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-650"><a href="https://iosdeveloperblog.com/category/libraries/charts/">Charts</a></li>
	<li id="menu-item-651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-651"><a href="https://iosdeveloperblog.com/category/libraries/code-quality/">Code Quality</a></li>
	<li id="menu-item-453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-453"><a href="https://iosdeveloperblog.com/category/libraries/color/">Color</a></li>
	<li id="menu-item-652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-652"><a href="https://iosdeveloperblog.com/category/libraries/command-line/">Command Line</a></li>
	<li id="menu-item-653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-653"><a href="https://iosdeveloperblog.com/category/libraries/concurrency/">Concurrency</a></li>
	<li id="menu-item-654" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-654"><a href="https://iosdeveloperblog.com/category/libraries/core-data/">Core Data</a></li>
	<li id="menu-item-655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-655"><a href="https://iosdeveloperblog.com/category/libraries/data-structures-algorithms/">Data Structures / Algorithms</a></li>
	<li id="menu-item-433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-433"><a href="https://iosdeveloperblog.com/category/libraries/database/">Database</a></li>
	<li id="menu-item-656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-656"><a href="https://iosdeveloperblog.com/category/libraries/deployment-distribution/">Deployment / Distribution</a></li>
	<li id="menu-item-657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-657"><a href="https://iosdeveloperblog.com/category/libraries/email/">Email</a></li>
	<li id="menu-item-658" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-658"><a href="https://iosdeveloperblog.com/category/libraries/eventbus/">EventBus</a></li>
	<li id="menu-item-659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-659"><a href="https://iosdeveloperblog.com/category/libraries/files/">Files</a></li>
	<li id="menu-item-660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-660"><a href="https://iosdeveloperblog.com/category/libraries/font/">Font</a></li>
	<li id="menu-item-661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-661"><a href="https://iosdeveloperblog.com/category/libraries/form-settings/">Form &#038; Settings</a></li>
	<li id="menu-item-662" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-662"><a href="https://iosdeveloperblog.com/category/libraries/functional-programming/">Functional Programming</a></li>
	<li id="menu-item-456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-456"><a href="https://iosdeveloperblog.com/category/libraries/games/">Games</a></li>
	<li id="menu-item-663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-663"><a href="https://iosdeveloperblog.com/category/libraries/gcd/">GCD</a></li>
	<li id="menu-item-664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-664"><a href="https://iosdeveloperblog.com/category/libraries/gesture/">Gesture</a></li>
	<li id="menu-item-665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-665"><a href="https://iosdeveloperblog.com/category/libraries/graphics/">Graphics</a></li>
	<li id="menu-item-666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-666"><a href="https://iosdeveloperblog.com/category/libraries/hardware/">Hardware</a></li>
	<li id="menu-item-448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448"><a href="https://iosdeveloperblog.com/category/libraries/image/">Image</a></li>
	<li id="menu-item-445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="https://iosdeveloperblog.com/category/libraries/xmljson/">JSON / XML</a></li>
	<li id="menu-item-667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-667"><a href="https://iosdeveloperblog.com/category/libraries/keyboard/">Keyboard</a></li>
	<li id="menu-item-668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-668"><a href="https://iosdeveloperblog.com/category/libraries/localization/">Localization</a></li>
	<li id="menu-item-669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-669"><a href="https://iosdeveloperblog.com/category/libraries/location/">Location</a></li>
	<li id="menu-item-452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-452"><a href="https://iosdeveloperblog.com/category/libraries/logging/">Logging</a></li>
	<li id="menu-item-670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-670"><a href="https://iosdeveloperblog.com/category/libraries/machine-learning/">Machine Learning</a></li>
	<li id="menu-item-671" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-671"><a href="https://iosdeveloperblog.com/category/libraries/maps/">Maps</a></li>
	<li id="menu-item-672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-672"><a href="https://iosdeveloperblog.com/category/libraries/math/">Math</a></li>
	<li id="menu-item-673" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-673"><a href="https://iosdeveloperblog.com/category/libraries/media-processing/">Media Processing</a></li>
	<li id="menu-item-682" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-682"><a href="https://iosdeveloperblog.com/category/libraries/messaging/">Messaging</a></li>
	<li id="menu-item-432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-432"><a href="https://iosdeveloperblog.com/category/libraries/networking/">Networking</a></li>
	<li id="menu-item-454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454"><a href="https://iosdeveloperblog.com/category/libraries/open-source-apps/">Open Source Apps</a></li>
	<li id="menu-item-685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-685"><a href="https://iosdeveloperblog.com/category/libraries/passbook/">Passbook</a></li>
	<li id="menu-item-686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-686"><a href="https://iosdeveloperblog.com/category/libraries/payments/">Payments</a></li>
	<li id="menu-item-450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-450"><a href="https://iosdeveloperblog.com/category/libraries/permissions/">Permissions</a></li>
	<li id="menu-item-687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-687"><a href="https://iosdeveloperblog.com/category/libraries/pdf/">PDF</a></li>
	<li id="menu-item-458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-458"><a href="https://iosdeveloperblog.com/category/libraries/reactive/">Reactive</a></li>
	<li id="menu-item-690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-690"><a href="https://iosdeveloperblog.com/category/libraries/regex/">Regex</a></li>
	<li id="menu-item-691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-691"><a href="https://iosdeveloperblog.com/category/libraries/sdk/">SDK</a></li>
	<li id="menu-item-692" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-692"><a href="https://iosdeveloperblog.com/category/libraries/security/">Security</a></li>
	<li id="menu-item-446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-446"><a href="https://iosdeveloperblog.com/category/libraries/security/">Security</a></li>
	<li id="menu-item-693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-693"><a href="https://iosdeveloperblog.com/category/libraries/server/">Server</a></li>
	<li id="menu-item-694" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-694"><a href="https://iosdeveloperblog.com/category/libraries/streaming/">Streaming</a></li>
	<li id="menu-item-695" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-695"><a href="https://iosdeveloperblog.com/category/libraries/string/">String</a></li>
	<li id="menu-item-696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-696"><a href="https://iosdeveloperblog.com/category/libraries/testing/">Testing</a></li>
	<li id="menu-item-4078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4078"><a href="https://iosdeveloperblog.com/category/libraries/toolslib/">Tools(Lib)</a></li>
	<li id="menu-item-457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-457"><a href="https://iosdeveloperblog.com/category/libraries/utilities/">Utilities</a></li>
	<li id="menu-item-699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-699"><a href="https://iosdeveloperblog.com/category/libraries/web-view/">Web View</a></li>
	<li id="menu-item-700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-700"><a href="https://iosdeveloperblog.com/category/libraries/websocket/">WebSocket</a></li>
	<li id="menu-item-701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-701"><a href="https://iosdeveloperblog.com/category/libraries/xcode/">Xcode</a></li>
</ul>
</li>
</ul>			</nav><!-- #site-navigation -->
		</div>

	</header><!-- #masthead -->

	<div id="content" class="site-content">

		<div class="container">

	<div id="main" class="site-main" role="main">

		
			<div id="posts" class="o-grid  o-grid--3col-@desk o-grid--2col-@lap archive__grid grid masonry">
				<style>#post-414{background:#ffeb00;padding:20px}</style><article id="post-414" class="post-414 post type-post status-publish format-aside hentry category-newsletter post_format-post-format-aside grid__item">

	<div class="hover__handler">
					<header class="entry-header">
								<a href="http://us15.campaign-archive1.com/home/?u=6150a4e2a19e4c0626d016e09&#038;id=e82136a68e" class="entry-permalink" rel="bookmark"><h1 class="entry-title">
</h1></a>			</header><!-- .entry-header -->
			</div>

	
	<div class="entry-content">
		<h2 style="text-align: left;">Sign up for our Awesome <strong>weekly</strong> <strong>Newsletter</strong>.</h2>
<p>&nbsp;</p>
<ul>
<li>Hand-curated with the <strong>best of the week</strong> iOS development News, Tools, Code snippets, Techniques, Productivity hacks, Tutorials, and Videos.</li>
<li>One email keeps you in the know</li>
<li>Delivered straight to your inbox every Friday morning</li>
<li><strong>Completely FREE</strong></li>
</ul>
<p>&nbsp;</p>
<style type="text/css">
	#mc_embed_signup{background:#ffeb00; clear:left; font:14px Helvetica,Arial,sans-serif; }<br />	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.<br />	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */<br /></style>
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="//iosdeveloperblog.us15.list-manage.com/subscribe/post?u=6150a4e2a19e4c0626d016e09&amp;id=e82136a68e" method="post" name="mc-embedded-subscribe-form" novalidate="">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<p><a title="View previous campaigns" href="http://us15.campaign-archive1.com/home/?u=6150a4e2a19e4c0626d016e09&amp;id=e82136a68e">View previous campaigns.</a></p>
<div id="mce-responses" class="clear"></div>
<p>&nbsp;</p>
<div style="position: absolute; left: -5000px;"><input tabindex="-1" name="b_6150a4e2a19e4c0626d016e09_e82136a68e" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p><script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';}(jQuery));var $mcj = jQuery.noConflict(true);</script></p>
	</div><!-- .entry-content -->

	
</article><!-- #post-## -->
<article id="post-8176" class="post-8176 post type-post status-publish format-link hentry category-swift category-tutorials post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://learnappmaking.com/comparing-classes-vs-structs-swift/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Beginner:</b><i> Comparing Classes vs. Structs in <b>Swift!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/beginner-comparing-classes-vs-structs-swift/" rel="bookmark"><time class="entry-date published" datetime="2017-06-03T16:44:49+00:00">June 3, 2017</time><time class="updated" hidden datetime="2017-06-03T21:09:44+00:00">June 3, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://learnappmaking.com/comparing-classes-vs-structs-swift/'><img class="aligncenter" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/classes-vs-structs-comparison-swift-programming-770.jpg" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">A</span> common mistake newcomer to Swift makes is to start with a class instead of a struct. That’s understandable since in Objective-C we use classes everywhere. There is nothing wrong in using a class since Swift still supports it but in; You can still use them with Swift of course. But in Swift, <code class="highlighter-rouge">struct</code> is way more powerful as their Objective-C counterpart in which they are not anymore limited to just a set of fields holding some values.</p>
<p>Instead, Swift’s <code class="highlighter-rouge">structs</code> have quite the same capabilities as classes — except inheritance — but instead are <strong>value-types</strong> (so copied every time you pass them in another variable, much like &#8216;<code class="highlighter-rouge">Int'</code> for example) whereas classes are <strong>reference types</strong>, passed by reference instead of being copied, like in Objective-C.</p>
<p>Check out this article below to learn more about their differences.</p>
<p>Source: <em><a href="https://learnappmaking.com/comparing-classes-vs-structs-swift/">Comparing Classes vs. Structs in Swift &#8211; LearnAppMaking</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/swift/">Swift</a><a href="https://iosdeveloperblog.com/category/tutorials/">Tutorials</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8172" class="post-8172 post type-post status-publish format-link hentry category-code category-xcode-tips post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://learnappmaking.com/debugging-fix-bugs-xcode-debugger-breakpoints/?utm_campaign=Indie%2BiOS%2BFocus%2BWeekly&#038;utm_medium=web&#038;utm_source=Indie_iOS_Focus_Weekly_123" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>XCode:</b><i> How To Find And Fix Bugs With The Xcode <b>Debugger!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/beginner-find-fix-bugs-xcode-debugger/" rel="bookmark"><time class="entry-date published" datetime="2017-06-03T16:33:31+00:00">June 3, 2017</time><time class="updated" hidden datetime="2017-06-03T23:24:18+00:00">June 3, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://learnappmaking.com/debugging-fix-bugs-xcode-debugger-breakpoints/?utm_campaign=Indie%2BiOS%2BFocus%2BWeekly&#038;utm_medium=web&#038;utm_source=Indie_iOS_Focus_Weekly_123'><img class="aligncenter" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/debugging-xcode-swift-770.jpg" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">F</span>inding and fixing bugs quickly and efficiently is an essential skill every developer needs to possess. There are many strategies that a developer can incorporate in debugging their code in XCode and this article details them in a clear and concise manner:</p>
<p>Source: <em><a href="https://learnappmaking.com/debugging-fix-bugs-xcode-debugger-breakpoints/?utm_campaign=Indie%2BiOS%2BFocus%2BWeekly&amp;utm_medium=web&amp;utm_source=Indie_iOS_Focus_Weekly_123">Debugging: How To Find And Fix Bugs With The Xcode Debugger &#8211; LearnAppMaking</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/code/">Code</a><a href="https://iosdeveloperblog.com/category/xcode-tips/">Xcode Tips</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8186" class="post-8186 post type-post status-publish format-link hentry category-code category-swift category-tutorials post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="http://ericasadun.com/2017/05/27/tests-that-dont-crash/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Swift:</b><i> Writing Unit Tests that don&rsquo;t <b>crash!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/swift-writing-unit-tests-dont-crash/" rel="bookmark"><time class="entry-date published" datetime="2017-06-03T15:21:22+00:00">June 3, 2017</time><time class="updated" hidden datetime="2017-06-03T15:54:21+00:00">June 3, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='http://ericasadun.com/2017/05/27/tests-that-dont-crash/'><img class="aligncenter size-full wp-image-8195" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/testcase.png" alt="" width="400" height="267" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">A</span>s developers, we spend an enormous amount of time writing clean and error free production code but often times the test cases are neglected and is littered with unsafe code. Check out this article below by Tim Vermeulen who shows some techniques and strategies to deal with unsafe code in your tests.</p>
<p>Source: <em><a href="http://ericasadun.com/2017/05/27/tests-that-dont-crash/">Tests that don’t crash — Erica Sadun</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/code/">Code</a><a href="https://iosdeveloperblog.com/category/swift/">Swift</a><a href="https://iosdeveloperblog.com/category/tutorials/">Tutorials</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8181" class="post-8181 post type-post status-publish format-link hentry category-code category-swift category-tutorials post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://medium.com/the-traveled-ios-developers-guide/uikit-global-functions-b38250c0ed5c" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Swift:</b><i> UIKit Global <b>Functions!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/swift-uikit-global-functions/" rel="bookmark"><time class="entry-date published" datetime="2017-06-03T15:03:32+00:00">June 3, 2017</time><time class="updated" hidden datetime="2017-06-03T15:08:10+00:00">June 3, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://medium.com/the-traveled-ios-developers-guide/uikit-global-functions-b38250c0ed5c'><img class="aligncenter size-full wp-image-8187" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/ui-2.jpg" alt="" width="400" height="267" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">A</span>s an iOS developer, you will find yourself using UIKit framework the most while developing applications. It defines the core components of an iOS application, from labels and buttons to table views and navigation controllers.</p>
<p>It&#8217;s refreshing when someone does the deep digging and finds some hidden gems so that the rest of the developer can benefit. One such article(linked below) was written by Jordan Morgan who provides some really great shortcuts and code snippets that will save you a bunch of time while using UIKit Framework.</p>
<p>Source: <em><a href="https://medium.com/the-traveled-ios-developers-guide/uikit-global-functions-b38250c0ed5c">UIKit Global Functions – The Traveled iOS Developer’s Guide – Medium</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/code/">Code</a><a href="https://iosdeveloperblog.com/category/swift/">Swift</a><a href="https://iosdeveloperblog.com/category/tutorials/">Tutorials</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## --><style>#post-5144{background:#32344F;padding:20px}#post-5144 *{color:#ffffff;}</style>
<article id="post-5144" class="post-5144 post type-post status-publish format-link hentry category-featured-library category-swift post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://github.com/juanpablofernandez/SwiftyOnboard" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Featured Library:</b><i> A swifty iOS framework for creating beautiful onboarding <b>experiences!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/featured-library-a-swifty-ios-framework-for-creating-beautiful-onboarding-experiences/" rel="bookmark"><time class="entry-date published" datetime="2017-06-03T12:24:49+00:00">June 3, 2017</time><time class="updated" hidden datetime="2017-06-04T09:00:35+00:00">June 4, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://github.com/juanpablofernandez/SwiftyOnboard'><img class="aligncenter size-full" src="https://github.com/juanpablofernandez/SwiftyOnboard/raw/master/screenshots/onboard2.gif" width="300" height="532" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">S</span>wiftyOnboard makes it easy to add onboarding to any iOS application. SwiftyOnboard handles all of the logic behind the pagination of views, which allows you to quickly add a highly customizable onboarding to your app, all in a lightweight framework.</p>
<p>Source: <em><a href="https://github.com/juanpablofernandez/SwiftyOnboard">juanpablofernandez/SwiftyOnboard</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/featured-library/">Featured Library</a><a href="https://iosdeveloperblog.com/category/swift/">Swift</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8168" class="post-8168 post type-post status-publish format-link hentry category-appstore category-business category-marketing post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="http://www.appsposure.com/app-marketing-strategies/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Marketing:</b><i> 108+ Strategies to Boost Your App <b>Downloads!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/marketing-108-strategies-boost-app-downloads/" rel="bookmark"><time class="entry-date published updated" datetime="2017-06-02T13:24:20+00:00">June 2, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='http://www.appsposure.com/app-marketing-strategies/'><img class="aligncenter" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/appsposure_bannerFinal_Rev_Fb01-1200x655.jpg" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">C</span>heck out this infographic below that highlights some of the things you can do to really boost your app downloads. Many of those strategies may be obvious to an experienced developer, but if you are just starting off with App development then this information is just priceless.</p>
<p>Source: <em><a href="http://www.appsposure.com/app-marketing-strategies/">108+ App Marketing Strategies to Boost Your Downloads | Appsposure</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/appstore/">Appstore</a><a href="https://iosdeveloperblog.com/category/business/">Business</a><a href="https://iosdeveloperblog.com/category/marketing/">Marketing</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8163" class="post-8163 post type-post status-publish format-link hentry category-design post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://medium.com/tall-west/lets-ditch-the-nav-bar-3692cb17cc67" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Design:</b><i> All Thumbs, Why Reach Navigation Should Replace the Navbar in iOS <b>Design!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/thumbs-reach-navigation-replace-navbar-ios-design/" rel="bookmark"><time class="entry-date published" datetime="2017-06-02T13:14:37+00:00">June 2, 2017</time><time class="updated" hidden datetime="2017-06-02T13:15:04+00:00">June 2, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://medium.com/tall-west/lets-ditch-the-nav-bar-3692cb17cc67'><img class="aligncenter size-full" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/1*4jNN273rccNHZg7ebvXoag-400x201.png" width="2000" height="1003" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">C</span>heck out this excellent article by Brad Ellis who makes his case for the end of the Navigation bar in iOS design. It&#8217;s a fact that Apple is moving away from a Navbar oriented design to a design that prioritizes reachability. This can be distinctly seen in Apple&#8217;s latest incarnation of Apple Music and Maps apps where Apple has gotten ridden of the navigation bar and replaced with a more finger reachable interface.</p>
<p>Read on at the article below for more insights:</p>
<p>Source: <em><a href="https://medium.com/tall-west/lets-ditch-the-nav-bar-3692cb17cc67">All Thumbs, Why Reach Navigation Should Replace the Navbar in iOS Design</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/design/">Design</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-8148" class="post-8148 post type-post status-publish format-link hentry category-code category-swift category-tutorials post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://medium.com/ios-os-x-development/ios-how-to-build-a-table-view-with-collapsible-sections-96badf3387d0" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Tutorial:</b><i> How to build a Table View with Collapsible <b>Sections!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/tutorial-build-table-view-collapsible-sections/" rel="bookmark"><time class="entry-date published updated" datetime="2017-06-01T21:21:00+00:00">June 1, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://medium.com/ios-os-x-development/ios-how-to-build-a-table-view-with-collapsible-sections-96badf3387d0'><img class="aligncenter size-full" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/1*K5aIFXP1_b3btC5Mlygh3A-400x188.png" width="1440" height="677" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">C</span>heck out this tutorial below that details how to create collapsible sections in your table views.</p>
<p>Source: <em><a href="https://medium.com/ios-os-x-development/ios-how-to-build-a-table-view-with-collapsible-sections-96badf3387d0">iOS: How to build a Table View with Collapsible Sections</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/code/">Code</a><a href="https://iosdeveloperblog.com/category/swift/">Swift</a><a href="https://iosdeveloperblog.com/category/tutorials/">Tutorials</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## --><style>#post-8088 blockquote{border-color:#AE3425;}</style>
<article id="post-8088" class="post-8088 post type-post status-publish format-link hentry category-career post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://hired.com/blog/employers/whiteboard-interview-alternatives/?utm_source=customerio&#038;utm_medium=email&#038;utm_campaign=(b2c)(m-all)(c_newsletter_20170529_approved-not-hired_reactivation_NA_a1)" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Career:</b><i> The Whiteboard Interview is <b>Dead!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/career-whiteboard-interview-dead/" rel="bookmark"><time class="entry-date published" datetime="2017-06-01T15:59:40+00:00">June 1, 2017</time><time class="updated" hidden datetime="2017-06-01T16:01:22+00:00">June 1, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://hired.com/blog/employers/whiteboard-interview-alternatives/?utm_source=customerio&#038;utm_medium=email&#038;utm_campaign=(b2c)(m-all)(c_newsletter_20170529_approved-not-hired_reactivation_NA_a1)'><img class="aligncenter size-full" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/startup-photos-400x267.jpg" width="1125" height="750" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<blockquote><p>Can you imagine how long it would take to create your favorite product or app without using a computer to write the underlying code? And more importantly, why would you ever attempt to do it this way? That’s the question many developers ask themselves when they are asked in job interviews to write code by hand without the help of GitHub, StackOverflow or the myriad other tools they use to help them do their jobs on a daily basis.</p></blockquote>
<p>Read on at the link below for an insightful discussion about cons of the whiteboarding interview and some of the alternatives.</p>
<p>Source: <em><a href="https://hired.com/blog/employers/whiteboard-interview-alternatives/?utm_source=customerio&amp;utm_medium=email&amp;utm_campaign=(b2c)(m-all)(c_newsletter_20170529_approved-not-hired_reactivation_NA_a1)">The Whiteboard Interview is Dead &#8211; Here are 3 Alternatives</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/career/">Career</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-4171" class="post-4171 post type-post status-publish format-quote hentry category-articles post_format-post-format-quote grid__item">

	<div class="entry-permalink">
		
		<div class="entry-content">
						<div class="content-quote">
				<div class="flexbox">
					<div class="flexbox__item">
						<blockquote>" <em>Walking on water and developing software from a specification are easy if both are frozen.</em> "

- Edward V Berard</blockquote>					</div>
				</div>
			</div>
		</div>

	</div>

	
</article><!-- #post-## -->
<article id="post-8139" class="post-8139 post type-post status-publish format-link hentry category-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://www.macstories.net/stories/ios-11-ipad-wishes-and-concept-video/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>WWDC:</b><i> iOS 11 concept video for <b>iPad!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-ios-11-concept-video-ipad/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T21:01:46+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-06-02T03:41:58+00:00">June 2, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://www.macstories.net/stories/ios-11-ipad-wishes-and-concept-video/'><img class="aligncenter size-full wp-image-8152" src="https://iosdeveloperblog.com/wp-content/uploads/2017/06/Screen-Shot-2017-06-01-at-5.33.33-PM.png" alt="" width="400" height="241" /></a></a>		<div class="entry-content">
		<p><span class="aligncenter"><a href="https://www.youtube.com/watch?v=UyFUDQ5LLZw"></a></span></p>
<p><span class="dropcap">I</span>t&#8217;s been quite a while since Apple made major enhancements to iPad since the introduction of iOS 9.  iOS 9 represented a significant change in Apple&#8217;s approach to the iPad with features like Split View, Slide Over and Picture in Picture just to name a few. Interestingly Apple is also rumored to announce new versions of iPad specifically the 10.5 inch iPad Pro, which makes us believe that Apple might introduce a big refresh to iPad-only features with iOS 11.</p>
<p>iOS 11 announcement is still a few days away, but there is no harm in already dreaming about it. To make that easier here is an amazing concept video below created by Federico Viticci and Sam Beckett at MacStories.</p>
<p>Source: <a href="https://www.macstories.net/stories/ios-11-ipad-wishes-and-concept-video/">Macstories iOS 11 iPad concept video</a></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## --><style>#post-7874 blockquote{border-color:#AE3425;}</style>
<article id="post-7874" class="post-7874 post type-post status-publish format-link hentry category-articles tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://insights.hpe.com/articles/how-to-design-software-that-doesnt-crash-when-the-internet-connection-fails-1705.html" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Design apps to function remotely:</b><i> when Internet connection is <b>critical!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/design-apps-function-remotely-internet-connection-critical/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T15:58:22+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-05-31T16:00:35+00:00">May 31, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

				<div class="entry-content">
		<blockquote><p>Developers generally assume always-on connectivity and design their software with that premise. But such applications crash when they can&#8217;t reach the Internet or have poky connections. If you want happy users, design applications that can function remotely.</p></blockquote>
<p>The takeaway from this article is:</p>
<ul>
<li>Plan for the best way to gracefully handle both offline and low/intermittent connections.</li>
<li>Don’t assume that, because the local device has a strong connection, you have a good end-to-end connection.</li>
<li>Cache both incoming and outgoing data to improve offline/intermittent functionality.</li>
<li>Test caching and synchronization under a wide variety of conditions.</li>
</ul>
<p>Source: <em><a href="https://insights.hpe.com/articles/how-to-design-software-that-doesnt-crash-when-the-internet-connection-fails-1705.html">Design apps to function remotely when Internet connection is critical</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/articles/">Articles</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7869" class="post-7869 post type-post status-publish format-link hentry category-wwdc tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://techcrunch.com/2017/05/30/apple-went-full-dad-joke-with-the-names-of-this-years-secret-wwdc-panels/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>WWDC:</b><i> Apple plays with Humor for upcoming <b>WWDC</b> session <b>names!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-apple-plays-humor-upcoming-wwdc-session-names/" rel="bookmark"><time class="entry-date published updated" datetime="2017-05-31T15:47:44+00:00">May 31, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://techcrunch.com/2017/05/30/apple-went-full-dad-joke-with-the-names-of-this-years-secret-wwdc-panels/'><img class="aligncenter size-full wp-image-7870" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/Screen-Shot-2017-05-31-at-11.38.17-AM-1.png" alt="" width="400" height="125" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">E</span>very year before the WWDC keynote announcement, Apple keeps some of the session names a secret. Apple recently updated its WWDC 2017 sessions page with more information on the schedule for the week-long conference; Compared to previous years, this year Apple decided to add some humor to the cryptic session names. Read on to find out more.</p>
<p>Source: <em><a href="https://techcrunch.com/2017/05/30/apple-went-full-dad-joke-with-the-names-of-this-years-secret-wwdc-panels/">Apple went full dad joke with the names of this year’s secret WWDC panels | TechCrunch</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7860" class="post-7860 post type-post status-publish format-link hentry category-videos category-wwdc tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://daringfireball.net/thetalkshow/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b><b>WWDC</b> 2017:</b><i> Daring Fireball Talk <b>Show!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-2017-daring-fireball-talk-show/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T15:15:58+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-05-31T15:20:03+00:00">May 31, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://daringfireball.net/thetalkshow/'><img class="aligncenter size-full wp-image-7867" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/Screen-Shot-2017-05-31-at-11.18.42-AM.png" alt="" width="400" height="237" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">O</span>ne of the exciting things I look forward to during WWDC other than the keynote on day 1 is the live talk show hosted by John Gruber of Daring Fireball. <i>The Talk Show</i> touches upon a number of interesting topics and expands on some of the announcements made the previous day at the Worldwide Developers Conference keynote. <a href="http://daringfireball.net/thetalkshow/2016/06/17/ep-158">Last year</a> the special guests were Apple executives Phil Schiller and Craig Federighi who opened up about various WWDC announcements and gave an insight into why &amp; how Apple is making it a priority to address developer concerns.</p>
<p>This year&#8217;s talk show will also have special guests and an announcement on that will be made soon. The talk show will be streamed live on Daring Fireball podcast on Tuesday, June 6th. Bookmark the link below today.</p>
<p>Source: <em><a href="https://daringfireball.net/thetalkshow/">Daring Fireball: The Talk Show</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/videos/">Videos</a><a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7854" class="post-7854 post type-post status-publish format-link hentry category-articles tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="http://asciiwwdc.com/" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>WWDC:</b><i> Searchable full-text transcripts of all <b>WWDC</b> <b>sessions!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-searchable-full-text-transcripts-wwdc-sessions/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T13:43:21+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-05-31T14:52:34+00:00">May 31, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='http://asciiwwdc.com/'><img class="aligncenter size-full wp-image-7858" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/Screen-Shot-2017-05-31-at-10.50.16-AM.png" alt="" width="400" height="128" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">T</span>here is a ton of great information in WWDC video sessions but looking for the right content to view is difficult since you have to scrub through the videos to find that content you need. Do you wish there were an easier way? Now there is!</p>
<p>Check out the website below which provides a full transcript of each and every WWDC session since 2010 and allows full text searching inside of those transcripts.</p>
<p>Source: <em><a href="http://asciiwwdc.com/">ASCIIwwdc &#8211; Searchable full-text transcripts of WWDC sessions</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/articles/">Articles</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7847" class="post-7847 post type-post status-publish format-link hentry category-wwdc tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://itunes.apple.com/br/app/wwdc/id640199958?l=en&#038;mt=8" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>WWDC:</b><i> Don&rsquo;t forget to download the official iOS &amp; tvOS&nbsp;<b>app!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-dont-forget-download-official-ios-tvos-app/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T13:27:58+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-06-01T22:45:21+00:00">June 1, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://itunes.apple.com/br/app/wwdc/id640199958?l=en&#038;mt=8'><img class="aligncenter size-full" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/wwdc17-og-400x210.jpg" width="1200" height="630" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">A</span>pple Worldwide Developers Conference is just a few days away, and even if you are not attending the conference this year, you can still follow along each day&#8217;s event as it happens on iOS and tvOS. With the app, you can watch live streamed sessions and download WWDC videos for offline viewing; You can also watch streamed sessions from previous years. If you are attending the sessions, then the app is a must have since you can Browse session times, locations, and descriptions for sessions, labs, and special events and use indoor location to find your way around San Jose McEnery Convention Center. Add your pass to Wallet for faster check-in at WWDC.</p>
<p>If you are attending the conference in person, then the app is a must have; You can browse times, locations, and descriptions for sessions, labs, and special events and use indoor location to find your way around San Jose McEnery Convention Center. You also get the convenience of a faster check-in at WWDC. So why wait when you can download the app today at the link below:</p>
<p>Source: <em><a href="https://itunes.apple.com/br/app/wwdc/id640199958?l=en&amp;mt=8">WWDC on the App Store</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7843" class="post-7843 post type-post status-publish format-link hentry category-wwdc tag-newsletter tag-wwdc post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://wwdc.io/?ref=iosdeveloperblog" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>WWDC:</b><i> Yes, there is now a Mac app for <b>that!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/wwdc-yes-now-app/" rel="bookmark"><time class="entry-date published" datetime="2017-05-31T13:08:15+00:00">May 31, 2017</time><time class="updated" hidden datetime="2017-05-31T13:54:52+00:00">May 31, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://wwdc.io/?ref=iosdeveloperblog'><img src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/hero@2x.png"></a>		<div class="entry-content">
		<p></p>
<p><span class="dropcap">A</span> new version of the unofficial Mac app for WWDC is now out&nbsp;with a brand new dark design and some innovative features. The best part about the app is that it&#8217;s completely free and <a href="https://github.com/insidegui/WWDC">open source</a>.&nbsp;With this app, you can see the schedule, watch sessions live as well as sessions from previous years. A new feature that they have introduced is the bookmarking feature. With bookmarks, you can mark a specific point within a video and add an annotation to it, this way it&#8217;s easier to refer back to specific topics that are interesting to you. Be sure to download the app at the link below:</p>
<p>Source: <em><a href="https://wwdc.io/?ref=iosdeveloperblog">The unofficial WWDC app for macOS</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/wwdc/">WWDC 2017</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
<article id="post-7878" class="post-7878 post type-post status-publish format-link hentry category-featured-library category-swift tag-libraries tag-newsletter post_format-post-format-link grid__item">

	<header class="entry-header">
		<a href="https://github.com/krisk/fuse-swift" class="entry-permalink" rel="bookmark"><h1 class="entry-title"><b>Library:</b><i> A lightweight fuzzy-search <b>library!</b></i>
</h1></a>		
			<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__author">by <a href="https://iosdeveloperblog.com/author/myidb/" title="Posts by Esh Satrasala" rel="author">Esh Satrasala</a> | </span>
			<span class="entry-meta__primary"><span class="screen-reader-text">Posted on</span> <a href="https://iosdeveloperblog.com/library-lightweight-fuzzy-search-library/" rel="bookmark"><time class="entry-date published" datetime="2017-05-30T16:12:58+00:00">May 30, 2017</time><time class="updated" hidden datetime="2017-06-01T22:48:28+00:00">June 1, 2017</time></a></span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

		<a href='https://github.com/krisk/fuse-swift'><img class="aligncenter size-full wp-image-8156" src="https://iosdeveloperblog.com/wp-content/uploads/2017/05/Screen-Shot-2017-06-01-at-6.46.41-PM.png" alt="" width="400" height="366" /></a>		<div class="entry-content">
		<p><span class="aligncenter"></span></p>
<p><span class="dropcap">F</span>use is a super lightweight library which provides a simple way to do fuzzy searching. If you are not familiar with fuzzy searches, it&#8217;s a type of search that will find matches even when users misspell words or enter in only partial words for the search. If you use search in your app then you should take a deeper look into this library since it can give a big boost to the usability of your app and your users will love it.</p>
<p>If you use any kind of search in your app then you should take a deeper look into this library. A feature like this can provide a big boost to the usability of your app and your users will love it.</p>
<p>Source: <em><a href="https://github.com/krisk/fuse-swift">GitHub &#8211; krisk/fuse-swift</a></em></p>
		</div>
	</header><!-- .entry-header -->

		<footer class="entry-footer">
		
		<div class="entry-meta">
			<span class="entry-meta__secondary"><span class="cat-links">
<a href="https://iosdeveloperblog.com/category/featured-library/">Featured Library</a><a href="https://iosdeveloperblog.com/category/swift/">Swift</a></span>
</span>

		</div><!-- .entry-meta -->
	</footer><!-- .entry-footer -->

	
</article><!-- #post-## --><article id="post-" class="">

	<div class="hover__handler">
					<header class="entry-header">
				<a href="" class="entry-permalink" rel="bookmark"><h1 class="entry-title">
</h1></a>			</header><!-- .entry-header -->
			</div>

	
</article><!-- #post-## -->			</div>

			
		<nav class="pagination" role="navigation">
			<h1 class="screen-reader-text">Posts navigation</h1>

			<div class="nav-links">

				<span class="prev page-numbers disabled"><i class="fa fa-long-arrow-left prev-arrow"></i>Previous</span><span class='page-numbers current'>1</span>
<a class='page-numbers' href='https://iosdeveloperblog.com/page/2/?ref=producthunt'>2</a>
<a class='page-numbers' href='https://iosdeveloperblog.com/page/3/?ref=producthunt'>3</a>
<span class="page-numbers dots">&hellip;</span>
<a class='page-numbers' href='https://iosdeveloperblog.com/page/14/?ref=producthunt'>14</a>
<a class="next page-numbers" href="https://iosdeveloperblog.com/page/2/?ref=producthunt">Next<i class="fa fa-long-arrow-right next-arrow"></i></a>
			</div><!-- .nav-links -->

		</nav><!-- .navigation -->
	
	</div><!-- #main -->
</div><!-- .container -->

</div><!-- #content -->

<footer id="colophon" class="site-footer" role="contentinfo">
	<div class="container">
		<div class="grid">
			<div class="grid__item  site-info">

				©Copyright 2017 - iOS Developer Blog <a href="https://pixelgrade.com/themes/hive/" title="HIVE - A Magazine Style WordPress Theme" rel="theme">Hive Theme</a> <span>by</span> <a href="https://pixelgrade.com" title="The PixelGrade Website" rel="designer">PixelGrade</a>
			</div><!-- .site-info -->

			<div class="grid__item  footer-navigation">
				<nav><h5 class="screen-reader-text">Footer navigation</h5><ul id="menu-footer-menu" class="nav  nav--footer"><li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://iosdeveloperblog.com/contact/">Contact</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://iosdeveloperblog.com/rss-feed/">RSS Feed</a></li>
<li id="menu-item-291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291"><a href="https://iosdeveloperblog.com/sponsorship/">Sponsorship</a></li>
<li id="menu-item-333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-333"><a href="https://twitter.com/iosdevelopblog">Twitter</a></li>
<li id="menu-item-319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-319"><a href="https://iosdeveloperblog.com/newsletter/">Newsletter</a></li>
</ul></nav>			</div>
		</div>
	</div><!-- .site-footer .container -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<div class="toolbar">
		<div class="toolbar__head">
			<nav id="social-navigation" class="toolbar-navigation" role="navigation">
				<h5 class="screen-reader-text">Secondary navigation</h5>
									<ul class="nav  nav--toolbar">
						<li class="nav__item--search"><a href="#">Search</a></li>
					</ul>
							</nav>
			<!-- #social-navigation -->
		</div>
		<div class="toolbar__body">
					</div>
	</div>
	<div class="overlay--search">
		<div class="overlay__wrapper">
			<form role="search" method="get" class="search-form" action="https://iosdeveloperblog.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			<p>Begin typing your search above and press return to search. Press Esc to cancel.</p>
		</div>
		<b class="overlay__close"></b>
	</div>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-content/themes/hive/assets/js/imagesloaded.js?ver=3.1.8'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-content/themes/hive/assets/js/jquery.hoverIntent.js?ver=1.8.0'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-content/themes/hive/assets/js/velocity.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-content/themes/hive/assets/js/main.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var GEM = {"thankyou":"Thank you for signing up!","thankyou_suppressed":"Thank you for signing up! Please check your email to confirm your subscription.","oops":"Oops! There was a problem. Please try again.","email":"Please enter a valid email address.","required":"%s is a required field."};
/* ]]> */
</script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-content/plugins/godaddy-email-marketing-sign-up-forms/js/gem.min.js?ver=1.2.0'></script>
<script type='text/javascript' src='https://iosdeveloperblog.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>

</body>
</html>